Print Console™ for Windows NT®

February 1999

This document describes the installation and operation of Software Shelf’s Print Console software.

Software Version:  Version 3.0


© 1999 Intrust Software, Los Angeles, CA.

The Software described in this document is owned by Intrust Software, and is protected by United States copyright laws and international treaty provisions. Therefore, you must treat the Software like any other copyrighted material (e.g., a book or musical recording) except that you may either (a) make one copy of the Software solely for backup or archival purposes, or (b) transfer the Software to a single hard disk provided you keep the original solely for backup or archival purposes. You may not copy the user documentation provided with the Software, except for your own authorized use.

RESTRICTED RIGHTS LEGEND

The Software and documentation are provided with RESTRICTED RIGHTS. Use, duplication, or disclosure by the government is subject to restrictions as set forth in subparagraph (c)(1)(ii) of the Rights in Technical Data and Computer Software clause at DFARS 252.227-7013 or subparagraphs (c)(1) and (2) of the Commercial Computer Software-Restricted Rights at 48 CFR 52.227-19 as applicable.

Manufacturer is Intrust Software, Exclusively licensed to Software Shelf International, Inc., 601 Cleveland Street, Suite 710, Clearwater, FL 33755

The following are trademarks owned by Software Shelf International, Inc.: Software Shelf Print Console

Windows NT is a registered trademark owned by Microsoft Corporation

All other trademarks are the property of their respective owners.
# Table of Contents

**Introduction**  
Getting Started ................................................................. 4

**Installation**  
Installing Print Console ............................................................. 7  
Upgrading From Previous Versions ........................................ 7  
Registering .................................................................................. 7  
Registry entries .......................................................................... 7

**Using Print Console**  
Using the PrintFolders View .......................................................... 8  
Using the Network Tab ................................................................. 8  
Using the Browse for Printer Dialog ........................................... 9  
Using the Document View ............................................................ 9  
Customize Colors Dialog ............................................................. 9

**How To...**  
How to make a copy of a printer ...................................................... 10  
How to Create and Delete PrintFolders ....................................... 10  
How To Add Printers To A PrintFolder .................................... 10  
How to add all printers on a domain or a network to a folder ............ 10  
How to operate on more than one printer at a time ....................... 10  
Tips on using PrintFolders ......................................................... 11  
How to Colorize the printers and folders in the PrintFolders View .... 11  
How to reorder columns in the document view ............................ 11  
How to add user tools to the menu .............................................. 11  
How to customize the toolbar ..................................................... 11

**Menus**  
File Menu .................................................................................. 12  
View Menu ................................................................................ 12  
PrintFolders Menu ................................................................... 12  
Printer Menu ............................................................................ 13  
Document Menu ........................................................................15  
Tools Menu ............................................................................... 16  
Help Menu .............................................................................. 17

**Troubleshooting**  
Where to find technical support ..................................................... 19

**Index** .................................................................................. 20
Introduction


Printers may be directly connected to a Windows Print Server via a COM port, LPT port or network-connected (either through a built-in network card or via a device which interfaces the network to an LPT1 style connector). (This device is often called a “Printer Server” – do not confuse this with the Windows Print Server machine).

Print Console gives you the power to:

• Control multiple printers with the click of a button.
• Arrange printers into logical groups, allowing you to perform actions on groups of printers that you select.
• View print jobs from multiple printers, all in one view.
• Make copies of existing printers with the click of a button.
• Automatically add locate and track printers in a domain, or even in an entire network.

You can also:

• Colorize printers based on criteria you select. Such as “Printers with error show up in red”
• Sort printers based on criteria you select. Such as “Order printers by document count”, so the busiest printers show up on top.

Print Console components

Print Console consists of a Windows NT application runs on the any Windows NT Server or Workstation on your network.

Unlimited users/printers

Print Console supports an unlimited number of printers in a domain.

Use the Table of contents to view all available topics.

Getting Started

Let’s get started by taking a look at the main Print Console Window, and examining it’s parts.

The main Print Console window is comprised of two main elements. The “Printer List” on the left, and the “Document View” on the right.
Printer List

The Printer List is used for the selection and management of printers. There are two different modes which you can use to select printers, either through the PrintFolders tab, or through the Network tab.

The PrintFolders tab allows grouping of printers into logical “folders” which you create. Printers can be sorted by their name, document count or status. Clicking on a print folder allows you to perform actions on all printers in the folder, such as pausing/resuming/purging, etc. The Network tab allows you to navigate directly to a printer in your network, and manage it. There is no need to install the printer first (as in Windows NT). See also: Using the PrintFolders View

Document View
The Document View shows all of the documents for the selected printer(s). Documents can be paused/restarted/deleted etc. The Document View supports sorting by any of the columns, both ascending and descending. The Document View also supports customizing the column layout, so you can drag-and-drop the columns into the order that you want them. See Also: Using the Document View.
Installation

Installing Print Console

Installation is quick and simple. You need only to select the path where Print Console will be installed, and the shortcut group for the start-menu items. It’s that easy.

1. Insert the Print Console CD-ROM into the appropriate drive in your Windows Server/Workstation.

2. Print Console setup should launch automatically once the CD is inserted.

3. If it doesn’t, from the Windows Explorer File Manager, run the SETUP.EXE file on the CD.

4. Follow the installation instructions that appear.

5. After a short period of copying files, the Print Console program group is created and the installation is complete.

6. Print Console setup will only ask you to reboot if some of the files it needed to copy were in-use. Rebooting ensures that these files are properly copied into place.

7. If the Print Console install does not tell you to reboot, then you can start using the product immediately.

Upgrading From Previous Versions

Before upgrading, please be sure to uninstall any earlier version of Print Console, either beta or production. You must uninstall previous versions before installing the new one.

Note: Failure to reboot after de-installation can result in registry entries relating to an earlier version being left on your system, causing Print Console to function incorrectly. See the Troubleshooting section if you suspect this may have occurred.

Registering

After installation be sure to register Print Console through our web site http://www.softwareshelf.com or call us at 727-445-1920. This ensures you receive your free 90 days of Print Console technical support.

Registry entries

Installing Print Console on a clean system (no previous install of any version) will generate the following registry settings:

```
HKEY_CURRENT_USER\Software\Intrust Software\Print Console
HKEY_LOCAL_MACHINE\Software\Intrust Software\Print Console
```
Using Print Console

Using the PrintFolders View

The PrintFolders View is designed to allow you to organize your printers into logical groups for easier management and display.

PrintFolders are useful because they allow you to view all of the jobs for a group of printers all at one time. They also show a summary of the printers they contain in their document count. Creating your own folders and adding printers to them is easy.

All of the functions relating to the PrintFolders view can be accessed by right-clicking on an item (any item, folder, printer, etc). For example, to add a folder, right-click on an existing folder, on in the white space, and then click “Add-Folder”.

Adding printers to a folder is also easy. Simply right-click on the folder and click “Add Printer To Folder”. The Browse for Printer Dialog will be displayed. The Browse for Printer Dialog is a fast easy way to add one or more printers to your folder. Navigate to the domain/server/printer and click OK. You can select as many printers as you want from as many different domains/servers. Adding all of the printers from an entire domain is simple, just click the domain, then click OK. Print Console will automatically search for every server with shared printers, and add them to the print folder.

(Note: Do not confuse adding a printer to a folder, with “installing a printer”. When you add a printer to a folder, you are really adding a “shortcut” to the folder, and not installing a new printer. To install a new printer, use the printer menu)

PrintFolders show the sum of the document counts for all of their printers. This is useful, as you can collapse the print folder and show only the document count for each folder. When you select a print folder, it’s name appears on the top in the “Selection” area.

TIP

When Print Console runs for the first time, it will create a folder called “Local Printers”, and will automatically add every local printer to this folder.

TIP

You will notice when Print Console loads that it initializes the printers in the PrintFolders view, it does this in order of appearance. While this initializing is in progress, you can still use Print Console. Sorting is not performed until all printers have been initialized.

Using the Network Tab

The network tab allows you to browse directly to a server and manage a print queue without installing it. For more robust management capabilities, use the PrintFolders tab.
Using the Browse for Printer Dialog

The Browse for Printer Dialog is used to add printers to a PrintFolder. You can either type the printer name directly into the edit box at the top of the dialog, or browse to the printer. You can select the entire network, a domain, a server or a specific printer. When you select a network, domain or server, Print Console will automatically search for all printers in that area. See How to add all printers on a domain or a network to a folder for more information.

Using the Document View

The document view is used to control the documents which are in the printer or printers currently selected. If a single printer is selected, the printer name will appear in the “Selection Bar”. The document view will refer to the print jobs for that printer only. If you are viewing multiple printers by selecting a PrintFolder, then the document view will display the jobs for all of the printers in the PrintFolder. The printer column is useful in this scenario to show you which printer each job is related to.

Multiple jobs can be selected at one time by drag-selecting in the document column or by using the shift/ctrl keys while clicking.

The document view has several features which may not be readily apparent, these are:

1. Columns are moveable, try dragging and dropping the columns into the order you want them to appear. When you reload Print Console, the positions will be restored.

2. Full sorting support, just click on the column. You can also right-click and select Sort. Sorting is available for all columns.

Customize Colors Dialog

The customize colors dialog can be used to set the colors for both printers and PrintFolders. For Printers, you can set colors for two criteria, either the document count or the error status.

To set the color based on the document count for either a printer or folder, click on the color well button, and select the color you want to use, then click in the edit field and set the document limit. When the document count exceeds the limit that you set, the printer/folder will turn the selected color.

Note: Many printers do not report their error status properly, so setting the colors for the printer error state does not work with all printers. This is due to the printer driver not properly reporting the error state to Windows.
How To...

How to make a copy of a printer

Right-Click on the printer you wish to copy and select “Install a copy of this printer”. In the “Duplicate Printer Installation” dialog, enter the new printer name and the new share name. You can also add any number of copies that you wish.

When making more than one copy of a printer, Print Console will add a number to the end of each printer name.

TIP

Using the string “%d” in the printer name and share name will control where the sequence number is inserted. For example, using the name “%d Copied Printer” will generate printer names: “1 Copied Printer”, “2 Copied Printer”, etc.

How to Create and Delete PrintFolders

Right click on the PrintFolders view, and select “New Folder”. The new folder will be added to the bottom of the PrintFolders view, and you will be able to edit the folder name.

To delete a folder, right click on the folder and select “Delete Folder”. You can also select the folder, then press the Delete key.

How To Add Printers To A PrintFolder

Right click on the PrintFolders view, and select “New Folder”. The new folder will be added to the bottom of the PrintFolders view, and you will be able to edit the folder name.

To delete a printer, right click on the printer and select “Remove Printer From Folder”. You can also select the printer, then press the Delete key.

How to add all printers on a domain or a network to a folder

Right-Click the folder which you want to add the printers to, and select “Add Printer to Folder”. Navigate to the domain you want to add and click the selection checkbox. You do not need to expand the domain, simply click the selection checkbox. Print Console will then display a dialog while it locates all of the printers in the domain.

How to operate on more than one printer at a time

Selecting a folder which contains more than one printer allows you to operate on all the printers in the folder at once. See the Printer Menu for information on which commands work on a folder.
Tips on using PrintFolders

You can directly edit the “DefaultGroups.ini” file. This file contains the contents of the PrintFolders view.

How to Colorize the printers and folders in the PrintFolders View

Right click on the PrintFolders view, or click on the PrinterFolders menu, and select “Customize Colors”. See the Customize Colors Dialog for more information.

How to reorder columns in the document view

The columns in the Document View can be ordered by clicking on the columns and dragging them to new positions.

How to add user tools to the menu

Select the menu item “Tools->Customize User Tools”. Use this dialog to add your own custom commands to the tools menu. The menu items you add will be displayed in the Tools menu.

How to customize the toolbar

Select the menu item “Tools->Customize”. Once in this dialog, you can drag and drop items on the Print Console window to new locations. You can move menus to toolbars and vice-versa.
Menus

File Menu

The file menu offers the following commands:

- **Server Properties**: Shows properties for the local print server.
- **Exit**: Closes the application

View Menu

The View menu offers the following commands:

- **Toolbar**: Shows or hides the toolbar.
- **Status Bar**: Shows or hides the status bar.
- **Printer List**: Shows or hides the printer list view.
- **Refresh**: Refreshes the information displayed by Print Console. This is not normally necessary, as Print Console displays the latest data about all printers and jobs, as they change.

PrintFolders Menu

The PrintFolders menu offers the following commands, which provide you with the ability to control the PrintFolders view.

- **New Folder**: Creates a folder.
**Rename Folder**  
Change the name of a folder

**Delete Folder**  
Removes a folder.

**Add Printer to Folder**  
Adds a shortcut to a printer to the selected folder.

**Remove Printer from Folder**  
Removes the selected printer from the current folder.

**Sort**  
Allows printers to be sorted by various criteria.

**Show Server Names**  
Enables you to show or hide the server name for a given printer. This is useful for lengthy server names, which obscure the name of the printer.

**Customize Colors**  
Allows color selection for printers based on various criteria, such as a large document count, printers with errors, etc.

---

**Printer Menu**

The Printer menu offers the following commands, which provide you with the ability to control one or more printers. Most commands operate on both a single printer, or a print folder. When a print folder is selected, the command will operate on all printers in the print folder. Common commands also operate on both local and remote printers.

**Pause Printing**  
Pauses the selected printer(s). No jobs will print while a printer is paused.

**Support**

✔  *Multiple Printers*
Print Folders

Local and Remote Printers

Set As Default
Sets the selected printer as the default printer.

Support

Single Printer
Local Printer

Purge Print Documents
Deletes all print jobs in the selected printer.

Support

Multiple Printers
Print Folders
Local and Remote Printers

Install copy of this printer
Automatically installs one or more copies of the selected printer. Works with a single printer. Works with local and remote printers. The new printers will have the same settings as the selected printer. The newly created printers will be automatically added to the currently selected print folder.

Support

Single Printer
Local and Remote Printers

Add Printer
Install a new printer. Installs the printer on the local machine only.

Support

Adds Local Printers only
Delete Printer

Deletes the selected printer (uninstalls it). Note that this is different that removing a printer from a print folder (PrintFolders only contain shortcuts to printers, not actual printers).

Support

✓ Single Printers
✓ Local and Remote Printers

Document Defaults

Displays a property sheet which allows you to configure the defaults for all documents printed on this printer. Supports local printers only.

Support

✓ Single Printer
✓ Local Printer

Properties

 Displays a property sheet which allows you to configure all settings related to the printer.

Support

✓ Single Printer
✓ Local and Remote Printers. (Note: Properties are read-only when working with a remote printer.

Document Menu

The Document menu offers the following commands, which provide you with the ability to control one or more print jobs.

Pause

Pauses the selected document or documents
**Resume**
Resumes the printing of the selected document or documents

**Restart**
Restarts the printing of the selected document or documents

**Delete**
Deletes the selected document or documents from the printer

**Properties**
Allows configuration of certain job properties, including priority and job notification user.

**Sort**
Allows sorting of jobs in the document view by:

- ✔ Document Name
- ✔ Printer Name
- ✔ Status
- ✔ Page count
- ✔ Owner
- ✔ Time Submitted
- ✔ Job Number
- ✔ Priority
- ✔ Size

**Tools Menu**

The Tools menu offers the following commands, which provide you with the ability to customize the toolbars and menus:

**Customize**
Allows you to configure the buttons and menus. Your settings will be saved and appear that way each time you load the program.

**Options**
Allows access to global options.
Customize User Tools

Allows you to add up to nine customized tools to the tool menu. Each tool can have its own name, EXE file, command line and starting folder. This is useful for putting your various print related tools, so that they are easily accessible from Print Console. The tools you add will be displayed at the bottom of the Tools menu.

Help Menu

The Help menu offers the following commands, which provide you with help:

- **Help Topics**
  - Takes you to this help file.

- **About Print Console**
  - Show you version information about this product and allows access to our support web sites.
Troubleshooting

Print Console is too slow

Print Console has many features which are specifically designed for performance. Print Console is designed to handle thousands of printers with multiple thousands of print jobs, with little overhead, and fast performance. If you are experiencing slow-downs, you should try some of the following tips:

1. Turn turning off advanced printer error detection, through Tools->Options.
2. If it is related to a printer, try removing the printer and see if the problem goes away.
3. Try turning off sorting in both the PrintFolders view and the Document View.
Where to find technical support

Software Shelf provides technical support for Print Console for 90 days after the product has been purchased. Our technical support desk can be reached by:

**Phone:** 727-445-1920
**Fax:** 727-445-9223
**Email:** support@softwaresshelf.com

**Address:**
Software Shelf International, Inc.
601 Cleveland Street - Suite 710
Clearwater, FL 33755
USA
Index

C
Create and Delete PrintFolders................................................................. 8
Customize Colors Dialog ...................................................................... 15

D
Delete Folder ......................................................................................... 8
Delete key ............................................................................................. 8
Document Menu .................................................................................... 13

F
File Menu ............................................................................................ 9

G
Getting Started.................................................................................... 3

H
Help Menu .......................................................................................... 14
Create and Delete PrintFolders ................................................................. 8
How to add all printers on a domain or a network to a folder ....................... 8
How To Add Printers To A PrintFolder ..................................................... 8
How to add user tools to the menu .............................................................. 9
How to Colorize the printers and folders in the PrintFolders View ................... 8
How to Create and Delete PrintFolders ..................................................... 8
How to customize the toolbar ................................................................. 9
How to make a copy of a printer ............................................................... 7
How to operate on more than one printer at a time ..................................... 8
How to reorder columns in the document view ............................................ 9

I
Installing Print Console ......................................................................... 4
Introduction .......................................................................................... 2

N
New Folder ........................................................................................... 8

P
Press ........................................................................................................ 8
Delete key ............................................................................................. 8
Printer Menu ......................................................................................... 11
PrinterList Menu .................................................................................. 10
PrintFolders .......................................................................................... 8

R
Registering ............................................................................................ 5
Registry entries ....................................................................................... 5

T
Tips on using PrintFolders ..................................................................... 8
Tools Menu ............................................................................................ 14
Troubleshooting........................................................................................................14

U
Upgrading From Previous Versions.............................................................................5
Using the Browse for Printer Dialog...........................................................................7
Using the Document View ..........................................................................................7
Using the Network Tab...............................................................................................7
Using the PrintFolders View ......................................................................................6

V
View Menu..................................................................................................................9

W
Where to find technical support..................................................................................15